Вопрос по информатике:
Написать программу решения уравнения ах3 + bх = 0 для произвольных а, b.
На СИ
- 10.02.2018 00:30
- Информатика
- remove_red_eye 1178
- thumb_up 37
Ответы и объяснения 1
Его также можно представить в виде x(ax² + b) = 0
Это же равносильно системе
[ x = 0
[ x = ±√( -b / a )
Понятно, что решением этого уравнения, независимо от коэффициентов, будет всегда являться 0. Также уравнение будет иметь и другие корни, при a ≠ 0 и -b / a > 0, это x = ±√( -b / a )
Решение на С
#include
#include
int main() {
// Ввод данных
float a, b;
printf("a = ");
scanf("%f", &a);
printf("b = ");
scanf("%f", &b);
// Первый корень уравнения
printf("x1 = 0\n");
// Второй и третий корни уравнения
if (a != 0 && -b / a > 0) {
printf("x2 = %.3f \n", -sqrt(-b / a));
printf("x3 = %.3f \n", sqrt(-b / a));
}
return 0;
}
- 01.01.1970 00:00
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.