Вопрос по информатике:
Очень срочно!!! Составьте программу решения квадратного уравнения, если заданы его коэффициенты в условном операторе (If...then...else...)
- 11.04.2018 06:54
- Информатика
- remove_red_eye 17120
- thumb_up 25
Ответы и объяснения 1
var
a:integer;
b:integer;
c:integer;
d:integer;
begin
Writeln('введите число а');
Readln(a);
Writeln('введите число b')
;Readln(b);
Writeln('введите число c');
Readln(c);
d:=b*b-(4*a*c);
if d>0 then Writeln('x1=',(-b-Sqrt(D))/(2*a),' ','x2=',((-b+Sqrt(D))/(2*a))) ;
if d=0 then
Writeln('x1=',-b/(2*a))
else
Writeln('нет корней');
- 12.04.2018 07:21
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.