Вопрос по информатике:
Напишите программу,которая переставляет первую и последнюю цифры, введённого число,например,из числа 12345 должно получится 52341.
Pascal ABC.
Пожалуйста,с объяснением
- 17.02.2018 01:43
- Информатика
- remove_red_eye 9788
- thumb_up 35
Ответы и объяснения 1
var x: integer;
begin
writeln ('Введите четырехзначное число.');
read (x);
x:=x mod 10 * 1000 + x div 100 mod 10 * 100 + x div 10 mod 10 * 10 + x div 1000;
writeln ('Число после перестановки цифр:',x);
end.
ДЛЯ ЛЮБЫХ ЧИСЕЛ:
program znanija;
var n,m,c1,cp:integer;
k,i:byte;
begin
write('Введите число.');
readln(n);{например 12345}
cp:=n mod 10;{последняя цифра=5}
n:=n div 10;{число без последней цифры=1234}
m:=n;{запомним его}
k:=0;
while m>9 do{пока не останется 1 цифра}
begin
m:=m div 10;{первая цифра=1}
k:=k+1;{количество разрядов без первого=4}
end;
c1:=m;{запомним первую цифру=1}
for i:=1 to k do
begin
m:=m*10;{повышаем разряд числа, равного первой цифре=1000}
cp:=cp*10;{повышаем разряд последней цифры=5000}
end;
n:=(n-m)*10+c1+cp*10;{получаем число=(1234-1000)*10+1+5000*10=52341}
writeln('Число после перестановки цифр:',n);
end.
- 18.02.2018 00:14
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.