Вопрос по информатике:
20.2 (№ 987) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет. Значение выводить с точностью до десятых. Пример работы программы:
- 24.08.2017 11:54
- Информатика
- remove_red_eye 19078
- thumb_up 46
Ответы и объяснения 1
var sum,k,a: integer;
begin
readln(a);
sum:=0;
k:=0;
while a0 do
begin
if a mod 8=0 then begin
k:=k+1;
sum:=sum+a;
end;
readln(a);
end;
if k=0 then write('NO')
else write(sum/k:0:1);
end.
- 25.08.2017 03:05
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.