Вопрос по информатике:
Срочно!! Напишите программу, которая сортирует одномерный массив.
Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная – в ячейке должно содержаться произведение индексов, если сумма индексов нечетная – в ячейке должна содержаться сумма индексов.
- 19.12.2016 00:50
- Информатика
- remove_red_eye 8208
- thumb_up 23
Ответы и объяснения 1
Const
N = 13;
Var
A:array[1..N] of integer;
i,j:integer;
Begin
For i:= 1 to N do
Begin
A[i]:=random(21)-10;
Write(A[i],' ');
End;
WriteLn;
For j:= 1 to N do
For i:= 1 to N-1 do
if A[i]For i:= 1 to N do
Write(A[i],' ');
End.
2)
Var
A:array[1..4,1..4] of integer;
i,j:integer;
Begin
For i:= 1 to 4 do
Begin
For j:= 1 to 4 do
Begin
if (i+j) mod 2 = 0 then A[i,j]:=i*j
else A[i,j]:=i+j;
Write(A[i,j],' ')
End;
WriteLn
End;
End.
- 20.12.2016 05:25
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.