Вопрос по информатике:
НАДО РЕШИТЬ ДВУМЕРНЫМ МАССИВОМ!
Даны два числа n и m. Создайте двумерный массив A[n][m], заполните его таблицей умножения A[i][j]=i*j и выведите на экран. При этом нельзя использовать вложенные циклы, все заполнение массива должно производиться одним циклом.
Входные данные
Программа получает на вход два числа n и m – количество строк и столбцов, соответственно.
Выходные данные
Программа должна вывести полученный массив. Числа разделяйте одним пробелом.
Примеры
входные данные
3 3
выходные данные
0 0 0 0 1 2 0 2 4
- 03.01.2018 16:36
- Информатика
- remove_red_eye 4062
- thumb_up 14
Ответы и объяснения 1
A:array[0..100,0..100] of integer;
i,N,M:integer;
Begin
ReadLn(N,M);
For i:= 0 to N*M-1 do
Begin
A[i div N, i mod M]:=(i div N)*(i mod M);
Write(A[i div N, i mod M],' ')
End
End.
- 04.01.2018 22:46
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.