Вопрос по информатике:
1) Составьте программу вычисления произведения чисел от 1 до 10 (1*2*3*..*) 2)Составьте программу, которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10
3)Составьте программу, которая находит сумму квадратов чисел от 1 до 10
- 01.04.2018 05:43
- Информатика
- remove_red_eye 3913
- thumb_up 45
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var s:=Range(1,10);
Writeln(s.Aggregate(1,(p,q)->p*q));
Writeln('S=',s.Where(k->k.IsEven).Sum,', П=',
s.Where(k->k.IsOdd).Aggregate(1,(p,q)->p*q));
Writeln('S2=',s.Select(k->k*k).Sum)
end.
Результат
3628800
S=30, П=945
S2=385
- 02.04.2018 18:44
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.