Вопрос по информатике:
Помогите пожалуйста написать программу в PascalABC.NET : Найти все четырехзначные числа, сумма цифр1-го и 3-го разряда которых равна 6,а разность 2-го и 4-го равна -5
- 23.08.2017 23:26
- Информатика
- remove_red_eye 15399
- thumb_up 9
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
for var a:=1 to 6 do
for var c:=0 to 5 do
for var b:=0 to 4 do
for var d:=5 to 9 do
if (a+c=6) and (b-d=-5) then Write(a,b,c,d,' ');
Writeln
end.
Результат
1055 1156 1257 1358 1459 2045 2146 2247 2348 2449 3035 3136 3237 3338 3439 4025 4126 4227 4328 4429 5015 5116 5217 5318 5419 6005 6106 6207 6308 6409
- 24.08.2017 14:37
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.