Вопрос по информатике:
Напишите программу в Паскаль, пожалуйста
В одномерном массиве из 10 элементов вычислить произведение чётных и сумму нечётных.
- 18.07.2015 21:27
- Информатика
- remove_red_eye 10799
- thumb_up 21
Ответы и объяснения 2
var a:array[1..10] of integer; i:integer; s,p:longint;
begin
p:=1;
for i:=1 to 10 do
read(a[i]);
for i:=1 to 10 do
if a[i] mod 2 = 0 then p:=p*a[i] else s:=s+a[i];
write('произведение четных = ',p,' сумма нечетных = ',s);
end.
- 19.07.2015 01:53
- thumb_up 28
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-99,99); a.Println;
Writeln('Сумма элементов с четным значением ',
a.Where(x->x.IsEven).Sum);
Writeln('Произведение элементов с нечетным значением ',
a.Where(x->x.IsOdd).Aggregate(int64(1),(x,y)->x*y))
end.
Пример
45 -95 41 -26 -99 -96 77 -4 18 41
Сумма элементов с четным значением -108
Произведение элементов с нечетным значением 54780974325
- 20.07.2015 13:34
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.