Вопрос по информатике:
Наурыз коже - традиционное блюдо на празднике Наурыз. Рецепты его приготовления разнятся, но за основу берутся 7 обязательных компонентов.
Зная по рецепту количество каждого компонента на порцию и количество имеющих продуктов, определить максимальное количество гостей, которых можно угостить традиционным блюдом праздника Наурыз.
Формат входных данных. В первой строке вводятся 7 натуральных чисел - количество каждого компонента на порцию. Во второй строке вводятся 7 натуральных чисел - количество имеющихся продуктов. Все числа не превосходят 10^9
- 25.12.2015 00:25
- Информатика
- remove_red_eye 19251
- thumb_up 29
Ответы и объяснения 1
var r,p:array[1..n] of integer;
i,max:integer;
begin
for i:=1 to n do read(r[i]);
readln;
for i:=1 to n do read(p[i]);
readln;
max:=p[1] div r[1];
for i:=2 to n do
if p[i] div r[i] < max then max:=p[i] div r[i];
writeln('Максимальное количество гостей = ',max);
end.
Пример:
120 100 75 80 50 60 40
2000 1500 1000 500 500 400 400
Максимальное количество гостей = 6
- 26.12.2015 17:32
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.