Вопрос по информатике:
Дан массив из 30 элементов. Заполнить массив начиная с элемента a до элемента b двойками, а остальные элементы нулями и вывести весь массив на экран.
Известно, что 1<=a Формат ввода
Вводятся 2 целых числа 1<=a Формат вывода
Массив из 30 элементов
Пример
Ввод
2 10
Вывод
0 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
пожалуйста
- 25.09.2018 06:56
- Информатика
- remove_red_eye 13291
- thumb_up 31
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
1. Решение без проверки вводимых данных
begin
var a,b:integer;
Read(a,b);
var P:=ArrFill(30,0);
for var i:=a-1 to b-1 do P[i]:=2;
P.Println
end.
Пример
2 10
0 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
2. Решение с контролем ввода
begin
var a:=ReadInteger('Введите a от 1 до 30:');
if a<1 then begin Writeln('Неверно'); Exit end;
var b:=ReadInteger('Введите b от '+a.ToString+' до 30:');
if (b30) then begin Writeln('Неверно'); Exit end;
var P:=ArrFill(30,0);
for var i:=a-1 to b-1 do P[i]:=2;
P.Println
end.
Пример
Введите a от 1 до 30: 2
Введите b от 2 до 30: 10
0 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
- 26.09.2018 19:22
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.