Вопрос по информатике:
Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковые цифры, стоящие рядом (как, например, 221)
Желательно программу на Паскале
- 24.10.2017 07:53
- Информатика
- remove_red_eye 8622
- thumb_up 7
Ответы и объяснения 1
var a,temp: integer;
b: boolean;
begin
readln(a);
temp:=-a;
b:=false;
while a0 do
begin
if temp=(a mod 10) then begin
b:=true;
break;
end;
temp:= a mod 10;
a:=a div 10;
end;
if b then write('верно') else write('неверно');
end.
- 26.10.2017 00:05
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.