Вопрос по информатике:
1) составить программу(паскаль) вывода на экран трёхзначных нечётных чисел которые оканчиваются на 3
2) составить программу последов. чисел целых чисел определить наименьшее четное отрицательное число. О признак окончания ввода ( min = 30.000 )
3) последов. целых чисел найти среднее арифметических чётных чисел. О- признак окончания ввода ( integer, k 10000 ) s/n
- 05.04.2017 23:18
- Информатика
- remove_red_eye 16905
- thumb_up 49
Ответы и объяснения 1
//1
begin
for var i:=100 to 999 do if i mod 10 = 3 then print (i);
end.
//2
begin
var min:=30000; var n:=0;
repeat
n:=readinteger('Введите число: ');
if (n.iseven) and (n<0) and (n
write ('Min: ', min);
end.
//3
begin
var sum:=0; var n:=0; var a:=0;
repeat
a:=readinteger('Введите число: ');
if a.iseven then
begin
sum+=a;
inc (n);
end;
until a=0;
write ('Average: ',sum/(n-1));
end.
- 06.04.2017 20:58
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.