Вопрос по информатике:
Составить программу, печатающую значение true, если указанное высказывание является истинным и false- в противном случае
а) все цифры данного четырёхзначного числа N различны
- 14.12.2017 03:27
- Информатика
- remove_red_eye 1344
- thumb_up 50
Ответы и объяснения 1
r1,r2,r3:byte;
Begin
WriteLn('Введите четырёхзначное число');
ReadLn(N);
r1:=N div 1000;
r2:=(N div 100) mod 10;
r3:=(N div 10) mod 10;
N:=N mod 10;
Write((r1r2)and(r1r3)and(r1N)and(r2r3)and(r2N)and(r3N))
End.
- 15.12.2017 01:11
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.