Вопрос по информатике:
Задача на c++
Дан массив, состоящий из nn элементов. Требуется добавить в него число x на позицию p. При этом все элементы с позиций в диапазоне [p;n]должны сдвинуться на элемент вправо.
Формат входных данных
В первой строке входных данных дается число nn (1≤n≤100). В следующей строке даны n чисел, каждое из которых по модулю не превосходит 10 в 9 степени. На третьей строке даются число xx (также по модулю не превосходящее 10 в 9 степени) и число p (1≤p≤n+1). Все числа во входных данных целые.
Формат выходных данных
Требуется вывести обновленную последовательность, хранимую в массиве.
- 22.01.2018 17:57
- Информатика
- remove_red_eye 3237
- thumb_up 39
Ответы и объяснения 1
using namespace std;
int main() {
int n, x, p;
cin >> n;
int a[n+1];
for (int i=0; i
}
cin >> x >> p;
for (int i=n; i>p-1; i--){
a[i] = a[i-1];
}
a[p-1] = x;
for (int i=0; i
}
cout << "\n";
return 0;
}
Пример:
5
4 2 9 7 3
8 4
4 2 9 8 7 3
- 23.01.2018 19:45
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.