Вопрос по информатике:
Нужно написать программу на паскале обязательно используя цикл For.
Программа вычисляет среднее арифметическое положительных элементов ряда чисел. Каждый элемент ряда вычисляется по формуле: (12*K-21)/3, где K--номер элемента в ряду. Всего элементов--необходимо спросить.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 19.09.2016 22:03
- Информатика
- remove_red_eye 15545
- thumb_up 22
Ответы и объяснения 1
S:real;
Begin
n:=0;
Write('K = ');ReadLn(K);
For K:= 1 to K do
Begin
Write((12*K-21)/3,' ');
if (12*K-21)/3 > 0 then
Begin
S:=S+(12*K-21)/3;
n:=n+1
End;
End;
WriteLn;
Write('Sr = ',S/n)
End.
- 20.09.2016 11:32
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.