Вопрос по информатике:
1)используя справочник записать значение процедур delete и insert .
2)написать программу позволяющею разделить на отдельные цифры число любой длины
- 15.05.2017 02:21
- Информатика
- remove_red_eye 814
- thumb_up 24
Ответы и объяснения 1
procedure Insert(source: string; var s: string; index: integer);
Вставляет подстроку source в строку s с позиции indexprocedure Delete(var s: string; index, count: integer);
Удаляет из строки s count символов с позиции index
2)
var s:string; i,n,code:integer;
begin
write('Введите длинное число:');
readln(s);
for i:=1 to length(s) do
begin
val(s[i],n,code);
if code=0 then writeln(n);
end;
end.
Пример:
Введите длинное число:3456810285
3
4
5
6
8
1
0
2
8
5
Если не требуется выполнять арифметических действий с цифрами, то можно так:
var s:string; i:integer;
begin
write('Введите длинное число:');
readln(s);
for i:=1 to length(s) do writeln(s[i]);
end.
- 16.05.2017 14:10
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.