Вопрос по информатике:
Составьте программу определения количества четных и нечетных цифр в записи данного натурально числа
- 09.11.2017 13:30
- Информатика
- remove_red_eye 13890
- thumb_up 48
Ответы и объяснения 2
begin
write('n = ');
readln(n);
k1:=0; k2:=0;
while n>0 do
begin
if n mod 2=0 then k1:=k1+1 else k2:=k2+1;
n:=n div 10;
end;
writeln('Четных цифр - ',k1,', нечетных - ',k2);
end.
Пример:
n = 14568
Четных цифр - 3, нечетных - 2
- 01.01.1970 00:00
- thumb_up 33
var a,kn,kh: longint;
begin
kn:=0;
kh:=0;
readln(a);
while a>0 do
begin
if (a mod 10) mod 2=0 then kh:=kh+1
else kn:=kn+1;
a:= a div 10;
end;
writeln('кол-во четных: ',kh);
writeln('нечетных: ',kn);
end.
- 01.01.1970 00:00
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.