Вопрос по информатике:
Составить программу на Паскаль
Из массива Р, содержащего 10 элементов, сформировать массив Н по правилу:
Н(к)=I/P(к), (к -чётные), Н(к)=Р(к)+к, (к - нечётные)
В массиве, содержащем 10 элементов, нечётным элементам присвоить значения квадратов их индексов.
В массиве, содержащем 10 элементов, напечатать индекс последнего из элементов, равных 0.
- 11.12.2016 07:34
- Информатика
- remove_red_eye 1977
- thumb_up 8
Ответы и объяснения 1
begin
writeln('Введите элементы массива P: '); for i:=1 to 10 do begin readln(P[i]); end; writeln; writeln('Массив P: '); for i:=1 to 10 do begin write(' '+P[i]+' '); end;
writeln; writeln('Массив H: '); for i:=1 to 10 do begin if (i mod 2 = 0) then begin H[i]:=1/P[i]; end; if (i mod 2 0) then begin H[i]:=P[i]+i; end; end; for i:=1 to 10 do begin write(' '+H[i]+' '); end; writeln; writeln; writeln('Нечётным элементам присваиваем значения квадратов их индексов'); for i:=1 to 10 do begin if (i mod 2 0) then P[i]:=i*i; end; for i:=1 to 10 do begin if (i mod 2 0) then H[i]:=i*i; end; writeln('Массив P: '); for i:=1 to 10 do begin write(' '+P[i]+' '); end;
writeln; writeln('Массив H: '); for i:=1 to 10 do begin write(' '+H[i]+' '); end; writeln; writeln; writeln('Напечатать индекс последнего из элементов, равных 0'); for i:=1 to 10 do begin if (P[i] = 0) then index1:=i; end; writeln; writeln('Индекс для массива P: '+index1); for i:=1 to 10 do begin if (H[i] = 0) then index2:=i; end; writeln; writeln('Индекс для массива H: '+index2); end.
- 12.12.2016 03:15
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.