Вопрос по информатике:
Напишите программу , которая в последовательности натуральных чисел определяет мин. число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число кратное 3. Кол-во чисел не превыш. 30000. Программа должна вывести 1 число - мин. число, кратное 3
- 04.09.2018 18:25
- Информатика
- remove_red_eye 11271
- thumb_up 45
Ответы и объяснения 2
begin
assign (input, 'input.txt'); reset(input);
assign (output, 'output.txt'); rewrite(output);
readln(n);
min:=32767;
for (i):=1 to (n) do
begin
read(a);
if ((a
min:=a;
end;
write(min);
end.
- 05.09.2018 13:24
- thumb_up 12
begin
write('n = ');
readln(n);
min:=999999;
writeln('Вводите числа:');
for i:=1 to n do
begin
readln(a);
if (a mod 3=0)and(a
writeln('min = ',min);
end.
Пример:
n = 5
Вводите числа:
52
63
80
18
29
min = 18
- 06.09.2018 14:35
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.