Вопрос по информатике:
1. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 9.
2. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 8.
- 09.09.2017 15:08
- Информатика
- remove_red_eye 8498
- thumb_up 24
Ответы и объяснения 1
var n,a,min,i:integer;
begin
write('n = ');
readln(n);
min:=999999;
writeln('Вводите числа:');
for i:=1 to n do
begin
readln(a);
if (a mod 9=0)and(a
writeln('min = ',min);
end.
Пример:
n = 5
Вводите числа:
25
99
30
18
87
min = 18
2.
var n,a,s,i:integer;
begin
write('n = ');
readln(n);
s:=0;
writeln('Вводите числа:');
for i:=1 to n do
begin
readln(a);
if abs(a) mod 10=8 then s:=s+a;
end;
writeln('s = ',s);
end.
Пример:
n = 5
Вводите числа:
41
18
25
98
64
s = 116
- 01.01.1970 00:00
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.