Вопрос по информатике:
Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата. Например, 25^2=625 . Напишите программу, которая находит все автоморфные числа на отрезке [ a , b ] .
Входные данные
Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами. Гарантируется, что a ≤ b .
Выходные данные
Программа должна вывести в одну строчку все автоморфные числа на отрезке [ a , b ] , разделив их пробелами. Если таких чисел нет, программа должна вывести число -1.
Примеры
входные данные
20 100
выходные данные
25 76
На паскале, через циклы, пожалуйста.
- 06.04.2018 20:53
- Информатика
- remove_red_eye 2601
- thumb_up 31
Ответы и объяснения 1
begin
var flag := true;
var a := readinteger;
var b := readinteger;
for var i := a to b do
if (i * i).ToString.EndsWith(i.ToString) then
begin
write(i, ' ');
flag := false;
end;
if flag then write(-1)
end.
- 07.04.2018 20:00
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.