Вопрос по информатике:
В Тридевятом царстве завершился чемпионат лесорубов.
Правила определения победителя следующие: победителем считается тот лесоруб, который срубил за сутки наибольшее количество деревьев. А если таких лесорубов несколько, то победителем становится тот из них, кто при этом сделал как можно меньше ударов. Известно, что ни у каких двух лесорубов нет абсолютно одинакового результата.
Требуется написать программу, которая принимает на вход список участников, для каждого из которых задано его имя, а также то, сколько деревьев и за какое суммарное количество ударов он срубил, и выводит имя победителя.
- 16.08.2018 21:49
- Информатика
- remove_red_eye 9067
- thumb_up 22
Ответы и объяснения 1
name,m_name:string;
begin
readln(n);
max:=0; min:=5000;
for i:=1 to n do
begin
readln(name);
readln(pi,ti);
if pi>max
then begin m_name:=name; max:=pi; min:=ti; end
else if pi=max
then if ti
writeln(m_name);
end.
Пример:
4
John
10 123
Ringo
10 144
George
11 156
Paul
11 160
George
- 18.08.2018 00:44
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.