Вопрос по информатике:
Написать программу, которая печатает введенное слово, начиная с последней буквы C++
- 09.03.2018 11:47
- Информатика
- remove_red_eye 3056
- thumb_up 41
Ответы и объяснения 2
void RevStr(char* S,int l)
{
char c;
if (l > 1)
{
c=S[0];
S[0]=S[l-1];
S[l-1]=c;
RevStr(S+1,l-2);
}
}
int main(int argc, char* argv[])
{
char S[12]="Test of pen";
RevStr(S,11);
std::cout << S << std::endl;
return 0;
}
- 01.01.1970 00:00
- thumb_up 24
#include
using namespace std;
string s;
int main ()
{
cin >> s;
reverse (s.begin(), s.end());
cout << s;
return 0;
}
- 01.01.1970 00:00
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.