Вопрос по информатике:
Напишите программу. и блок-схему.
Вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.
- 08.01.2018 10:43
- Информатика
- remove_red_eye 14388
- thumb_up 17
Ответы и объяснения 1
const n = 15;
var i, imin, imax, m, min, max, j: integer;
a: array[1..n]of integer;
begin
Writeln('Введите числа в массив');
for i := 1 to n do
readln(a[i]);
for i := 1 to n do
write(a[i], ' ');
min := a[1];
max := a[1];
imin := 1;
imax := 1;
for j := 1 to n do
begin
if(a[j] > max) then
begin
max := a[j];
imax := j;
end;
if(a[j] < min) then
begin
min := a[j];
imin := j;
end;
end;
writeln();
writeln('индекс минимального элемента ', imin, ' индекс максимального элемента ', imax);
m := abs(imin - imax);
Writeln();
Writeln('Кол-во элементов между макс. и мин. элементами ', m - 1);
end.
- 09.01.2018 09:11
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.