Вопрос по информатике:
Составить программу определения количества положительных и отрицательных элементов массива целых чисел.
- 19.08.2015 00:28
- Информатика
- remove_red_eye 1323
- thumb_up 29
Ответы и объяснения 2
const n=10;
var a: array[1..n] of integer;
i,ko,kp: integer;
begin
randomize;
ko:=0;
kp:=0;
writeln('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]>0 then kp:=kp+1;
if a[i]<0 then ko:=ko+1;
end;
writeln;
writeln('кол-во пол: ',kp);
writeln('кол-во отр: ',ko);
end.
- 20.08.2015 16:32
- thumb_up 26
const n=10;
var a: array[1..n] of integer;
i,ko,kp: integer;
begin
randomize;
ko:=0;
kp:=0;
writeln('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]>0 then
if a[i]<0 then ko:=ko+1;
w
w
e
- 21.08.2015 20:43
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.