Вопрос по информатике:
Массив из 10 элементов заполняется целыми числами. Составьте программу, которая вычисляет среднее арифметическое элементов, заканчивающихся на цифру 7
- 20.11.2017 16:20
- Информатика
- remove_red_eye 16748
- thumb_up 32
Ответы и объяснения 1
K = 10;
Var
A:array[1..K] of integer;
S,i,n:integer;
Begin
S:=0;
n:=0;
Write('Исходный массив: ');
For i:= 1 to K do
Begin
A[i]:=random(201)-100;
Write(A[i],' ');
if A[i] mod 10 = 7 then
Begin
S:=S+A[i];
n:=n+1
End;
End;
WriteLn;
if n = 0 then WriteLn('В массиве нет элементов, оканчивающихся на семь')
else WriteLn('Среднее арифметическое элементов, оканчивающихся на семь: ',S/n);
End.
- 21.11.2017 01:44
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.