Вопрос по информатике:
Массив из 5 элементов заполняется целыми числами. Составьте программу, которая вычисляет количество пар элементов, у которых один элемент - нечетный, а модуль второго меньше 5. Парой элементов считаются два рядом стоящие элемента.
- 10.06.2018 20:02
- Информатика
- remove_red_eye 2741
- thumb_up 24
Ответы и объяснения 1
N = 5;
Var
A:array[1..N] of integer;
i,k:integer;
Begin
Write('Исходный массив: ');
For i:= 1 to N do
Begin
A[i]:=random(21)-10;
Write(A[i],' ');
End;
WriteLn;
k:=0;
For i:= 1 to N-1 do
if ((A[i] mod 2 0)and(abs(A[i+1])<5))
or((A[i+1] mod 2 0)and(abs(A[i])<5)) then k:=k+1;
WriteLn(k)
End.
- 11.06.2018 22:35
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.