Вопрос по информатике:
Написать программу на языке Паскаль: Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Опре-делить : а) за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.; б) через сколько месяцев размер вклада превысит 1200 руб.
- 15.07.2018 16:04
- Информатика
- remove_red_eye 4807
- thumb_up 12
Ответы и объяснения 1
begin
//a
s:=1000; ds:=0; k1:=0;
while ds<=30 do
begin
ds:=s*0.02;
s:=s+ds;
k1:=k1+1;
end;
writeln('k1 = ',k1);
//б
s:=1000; ds:=0; k2:=0;
while s<=1200 do
begin
s:=1.02*s;
k2:=k2+1;
end;
writeln('k2 = ',k2);
end.
Результат:
k1 = 22
k2 = 10
- 16.07.2018 17:33
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.