Вопрос по информатике:
Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т.е. большее 100) число x, при вводе которого алгоритм печатает 1. Паскаль var x, L, M: integer; begin readln(x); L := x - 12; M := x + 12; while L <> M do if L > M then L := L - M else M := M – L; writeln(M); end.
- 17.02.2018 21:34
- Информатика
- remove_red_eye 14457
- thumb_up 23
Ответы и объяснения 1
var
x: integer;
function f(x: integer): integer;
var
L, M: integer;
begin
L := x - 12;
M := x + 12;
while L M do
if L > M then
L := L - M
else M := M - L;
f := M;
end;
begin
for x := 100 to 100000 do
if f(x) = 1 then begin
writeln(x);
break;
end;
end.
Что делает алгоритм из задания? Ищет наибольший общий множитель чисел M и L. То что ответ должен быть 1, означает, что ищем взаимно простые числа
Ответ 101
- 18.02.2018 08:39
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.