Вопрос по информатике:
Напишите программу, которая запрашивает одно целое число-номер месяца, и определяет количество дней в этом месяце. При вводе неверного месяца должно быть выведено сообщение об ошибке.
- 10.09.2017 11:40
- Информатика
- remove_red_eye 2039
- thumb_up 49
Ответы и объяснения 1
begin
b := 30;
c := 31;
d := 29;
e := 28;
writeln('От 1 до 12');
readln(a);
if a = 1 then writeln(c);
if a = 2 then writeln(d,' или ',e);
if a = 3 then writeln(c);
if a = 4 then writeln(b);
if a = 5 then writeln(c);
if a = 6 then writeln(b);
if a = 7 then writeln(c);
if a = 8 then writeln(c);
if a = 9 then writeln(b);
if a = 10 then writeln(c);
if a = 11 then writeln(b);
if a = 12 then writeln(c);
else writeln('Неправильно');
end.
- 11.09.2017 13:08
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.