Вопрос по информатике:
Написать программу на языке паскаль, возведение числа в степень. Степень вводится с клавиатуры.
- 26.09.2017 21:07
- Информатика
- remove_red_eye 6516
- thumb_up 15
Ответы и объяснения 2
var n,i:integer; x,xn:real;
begin
write('x = ');
readln(x);
write('n = ');
readln(n);
xn:=1;
for i:=1 to n do xn:=xn*x;
writeln('xn = ',xn:6:3);
end.
Пример:
x = 2
n = 5
xn = 32
- 27.09.2017 17:23
- thumb_up 25
Var
P:integer;
St:real;
Begin
Write('Показатель степени(целое число) = ');ReadLn(P);
St:=1;
For P:= 1 to P do
St:=St*2;
WriteLn('2^',P,' = ',St);
End.
Пример:
Показатель степени(целое число) = 4
2^4 = 16
Степень и число вводится с клавы:
Var
P:integer;
St,O:real;
Begin
Write('Показатель степени(целое число) = ');ReadLn(P);
Write('Основание степени(вещественное число) = ');ReadLn(O);
St:=1;
For P:= 1 to P do
St:=St*O;
WriteLn(O,'^',P,' = ',St);
End.
Пример:
Показатель степени(целое число) = 3
Основание степени(вещественное число) = 2.5
2.5^3 = 15.625
- 28.09.2017 11:05
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.