Вопрос по информатике:
PascalABCnet.Помогите пожалуйста. Задайте массив из 10 элементов с помощью датчика случайных двухзначных положительных чисел. a)Определите количество четных элементов с четными индексами. Выведите на экран исходный массив и полученное количество.
б)Найдите произведение элементов, кратных 5. Выведите на экран исходный массив и полученное произведение.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 07.10.2015 20:22
- Информатика
- remove_red_eye 5552
- thumb_up 31
Ответы и объяснения 1
A:array[1..10] of integer;
k:integer:=0;
Begin
For var i:= 1 to 10 do
Begin
A[i]:=random(10,99);
Write(A[i],' ');
if (i mod 2 = 0)and(A[i] mod 2 = 0) then k+=1;
End;
WriteLn;
WriteLn('Количество четных элементов с четными индексами: ',k);
End.
Var
A:array[1..10] of integer;
P:real:=1;
Begin
For var i:= 1 to 10 do
Begin
A[i]:=random(10,99);
Write(A[i],' ');
if A[i] mod 5 = 0 then P*=A[i];
End;
WriteLn;
WriteLn('Произведение элементов, кратных 5: ',P);
End.
- 08.10.2015 09:36
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.