Вопрос по информатике:
Помогите решить задачу с информатики пж!!!))СРОЧНО!!!!35б
Нужно написать программу.
Дано 2 числа a і b. Поміняти їх значення місцями двома способами: 1) з використанням третьої змінної; 2) за допомогою арифметичних операцій.
- 21.02.2018 01:54
- Информатика
- remove_red_eye 13578
- thumb_up 25
Ответы и объяснения 1
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
//1
c:=a; a:=b; b:=c;
writeln('a = ',a,' b = ',b);
//2
a:=a+b; b:=a-b; a:=a-b;
writeln('a = ',a,' b = ',b);
end.
Пример:
a = 5
b = 8
a = 8 b = 5
a = 5 b = 8
- 22.02.2018 21:06
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.