Вопрос по информатике:
Напишите программу которая в последовательности целых чисел определяет количество чисел кратных 6 или 11.Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (pascal)
- 17.04.2017 09:57
- Информатика
- remove_red_eye 1080
- thumb_up 14
Ответы и объяснения 1
begin
n:=0;
writeln('Вводите числа:');
readln(a);
while a0 do
begin
if (a mod 6 = 0)or(a mod 11 = 0) then n:=n+1;
readln(a);
end;
writeln('n = ',n);
end.
Пример:
Вводите числа:
45
24
80
55
74
31
0
n = 2
- 18.04.2017 06:21
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.