Вопрос по информатике:
Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N.
Входные данные
Задано единственное число N
Выходные данные
Необходимо вывести количество нулей среди всех цифр числа N.
Примеры
входные данные
100
выходные данные
2
- 01.05.2018 21:41
- Информатика
- remove_red_eye 14179
- thumb_up 11
Ответы и объяснения 1
Begin
result:=0;
While A>0 do
Begin
if A mod 10 = 0 then result:=result+1;
A:=A div 10;
End;
End;
Var A:integer;
Begin
Read(A);
WriteLn(ABC(A));
End.
- 02.05.2018 08:28
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.