Вопрос по информатике:
Написать программу в Паскале, которая находит максимальное нечетное отрицательное число среди чисел ,уже записанных в готовом текстовом файле, и выводит результат в другой файл.
- 18.10.2017 04:08
- Информатика
- remove_red_eye 2320
- thumb_up 28
Ответы и объяснения 1
var a,max: integer;
f: text;
begin
assign(f,'input.txt');
reset(f);
max:=0;
while not eof(f) do
begin
read(f,a);
if (abs(a)>max) and (a<0) and (a mod 2 0) then max:=a;
end;
close(f);
assign(f,'output.txt');
rewrite(f);
write(f,max);
close(f);
end.
- 19.10.2017 08:07
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.