Вопрос по информатике:
Написать программу по задаче: Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа -сумма двух старших и сумма двух младших разрядов. 2. Полученные два числа записываются друг за другом в порядке невозрастания (без разделителей).
- 01.08.2015 09:47
- Информатика
- remove_red_eye 7684
- thumb_up 14
Ответы и объяснения 1
A,B:integer;
Begin
ReadLn(A);
B:=(A div 1000) + ((A div 100) mod 10);
A:=((A div 10) mod 10)+ (A mod 10);
if A>=B then Write(B,A)
else if B>=A then Write(B,A)
End.
- 02.08.2015 07:36
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.