Вопрос по информатике:
Напишите программу в PaskalABC , которая в последовательности натуральных чисел определяет максимальное чётное число.
Программа получает на вход количество чисел в последовательности , а затем сами числа . В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30000.Программа должна вывести одно число-максимальное чётное число .
Пример работы программы :
Входные данные :3,10,99,42
Выходные данные:42
- 01.05.2015 10:31
- Информатика
- remove_red_eye 15456
- thumb_up 17
Ответы и объяснения 1
N,A,M:word;
Begin
Read(N);
M:=0;
For N:=1 to N do
Begin
Read(A);
if (A>M)and(A mod 2 = 0) then M:=A;
End;
Write(M)
End.
- 02.05.2015 09:20
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.