Вопрос по информатике:
Составьте программу к следующей задаче:
Ученик начал решать задачи данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2часов и min2 минут. Составьте программу, позволяющую определить, сколько времени (в часах и минутах) ученик решал эти задачи.
- 08.09.2017 06:50
- Информатика
- remove_red_eye 13207
- thumb_up 40
Ответы и объяснения 1
using namespace std;
int main() {
int h1,min1,h2,min2,h,min,m;
cin >> h1 >> min1;
cin >> h2 >> min2;
m = (h2*60+min2)-(h1*60+min1);
h = m / 60;
min = m % 60;
cout << "h = " << h << " min = " << min;
return 0;
}
Пример:
1 55
3 15
h = 1 min = 20
- 09.09.2017 09:57
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.