Вопрос по информатике:
С++ Нужно написать программу которая бы распознавала наличие определённого символа в строке, например точка, если да то вывести ответ да если нет-нет. Попробовал написать таким образом но оно не работает:
#include
using namespace std;
int main(int argc, char** argv)
{
setlocale (LC_CTYPE, "Russian");
char string[5];
cout<<"vveidte stroku";
gets(string);
if(string==".")
cout<<"da";
else cout<<"no";
system("pause");
return 0;
}
- 08.06.2016 21:47
- Информатика
- remove_red_eye 3851
- thumb_up 7
Ответы и объяснения 1
using namespace std;
int main(int argc, char** argv)
{
setlocale (LC_CTYPE, "Russian");
string s;
int n=0;
cout<<"vveidte stroku\n";
getline (cin, s);
n = s.find(".");
if(n>=0)
cout<<"da";
else cout<<"no";
system("pause");
return 0;
}
Пример:
vveidte stroku
если да то вывести ответ да если нет-нет.
da
- 09.06.2016 14:24
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.