Вопрос по информатике:
Уровень C. Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Уровень D (на дополнительную оценку, не обязательная). Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.
- 21.09.2016 03:00
- Информатика
- remove_red_eye 10960
- thumb_up 17
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int n;
cin >> n;
int maxdigit = 0;
while (n > 0) {
int digit = n % 10;
if (digit > maxdigit)
maxdigit = digit;
n /= 10;
}
cout << maxdigit;
return 0;
}
Уровень D
#include
using namespace std;
int main(){
int n;
cin >> n;
int prev = -1;
while (n > 0) {
int digit = n % 10;
if (digit == prev) {
cout << "YES";
return 0;
}
prev = digit;
n /= 10;
}
cout << "NO";
return 0;
}
- 22.09.2016 20:38
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.