Вопрос по информатике:
НА c++ ПОЖАЛУЙСТА
Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке. При вводе неверного номера месяца должно быть выведено слово 'NO'.
Входные данные
Входная строка содержит единственное число – номер месяца (возможно, неверный).
Выходные данные
Нужно вывести название времени года (на английском языке), соответствующее введённому номеру месяца ('winter' – зима, 'spring' – весна, 'summer' – лето, 'autumn' – осень). Если введён неверный номер месяца, программы должна вывести слово 'NO'.
Примеры
входные данные
4
выходные данные
spring
- 07.09.2017 02:25
- Информатика
- remove_red_eye 11727
- thumb_up 47
Ответы и объяснения 1
using namespace std;
int main()
{
int num;
cin>>num;
if(num==1 || num==2 || num==12)
{cout<<"winter";}
else if (num==3 || num==5 || num==4)
{cout<<"spring";}
else if (num==6 || num==7 || num==8)
{cout <<"summer";}
else if(num==9 || num==10 || num==11)
{cout<<"autumn";} else cout<<"no";
return 0;
}
- 08.09.2017 22:33
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.