Вопрос по информатике:
Вопрос №591394 (тип: C)
Даны два целых числа a и b.
Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b
Входные данные:
В первой строке вводятся два целых числа a и b (a<=b, a,b не больше 100 по модулю)
Выходные данные:
Программа должна вывести одно число - среднее арифметическое квадратов всех целых чисел от a до b (c 2 знаками после запятой)
- 12.05.2018 00:00
- Информатика
- remove_red_eye 7699
- thumb_up 48
Ответы и объяснения 2
var a,b,i: integer;
sum,k: real;
begin
sum:=0;
k:=0;
readln(a,b);
for i:=a to b do
begin
sum:=sum+i*i;
k:=k+1;
end;
writeln(sum/k:6:2);
end.
- 13.05.2018 06:57
- thumb_up 35
using namespace std;
int main() {
int a, b;
cin >> a >> b;
int sum = 0;
for (int i = a; i <= b; i++)
sum += i * i;
cout.precision(2);
cout << fixed << (float) sum / (b - a + 1);
return 0;
}
- 14.05.2018 09:14
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.