Вопрос по информатике:
С++
Написать программу в которой генерируются 10 случайныx чисел в диапазоне от -5 до 30. Посчитать среднее арифметическое чисел которые больше 10.
(Использовать цикл for)
- 15.02.2015 22:31
- Информатика
- remove_red_eye 4724
- thumb_up 40
Ответы и объяснения 2
#include
#include
using namespace std;
int main() {
int sum = 0;
int cnt = 0;
srand(time(0));
cout << "Numbers: ";
for (int i = 0; i < 10; i++) {
int a = rand() % 36 - 5;
cout << a << " ";
if (a > 10) {
cnt++;
sum += a;
}
}
cout << "\nAverage value = " << (double) sum / cnt;
return 0;
}
- 16.02.2015 08:29
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.