Вопрос по информатике:
Дан массив целых чисел из 10 элементов поменять местами первый максимальный и последний отрицательный элементы массива. Составить программу в паскале
- 21.08.2016 09:40
- Информатика
- remove_red_eye 1539
- thumb_up 29
Ответы и объяснения 1
A:array[1..10] of integer;
i,m,o:integer;
Begin
WriteLn('Введите массив');
For i:= 1 to 10 do
Begin
Read(A[i]);
End;
m:=10;
For i:= 9 downto 1 do
if A[i]>=A[m] then m:=i;
For i:= 10 downto 1 do
if A[i]<0 then
Begin
o:=i;
Break
End;
if o = 0 then WriteLn('Отрицательных чисел нет!')
else
Begin
i:=A[o];
A[o]:=A[m];
A[m]:=i;
For i:= 1 to 10 do
Write(A[i],' ')
End;
End.
- 22.08.2016 15:28
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.