Вопрос по информатике:
Напишите программу в Паскале, где дано натуральное число n и вычислить произведение первых n-сомножителей:
а) 1*3/2*5/3...
б) 1*1/3*1/5...
- 27.08.2018 13:43
- Информатика
- remove_red_eye 16276
- thumb_up 37
Ответы и объяснения 1
N,i,j:integer;
P:real;
Begin
i:=1;
j:=1;
P:=1;
WriteLn('Введите число N');
ReadLn(N);
Write('а:1');
While in do
begin
j:=j+2;
i:=i+1;
P:=P*(j/i);
Write('*',j,'/',i);
end;
Write('=',P);
WriteLn();
Write('б:1');
i:=1;
j:=1;
P:=1;
While in do
begin
j:=j+2;
i:=i+1;
P:=P/i;
Write('*1/',j);
end;
Write('=',P);
End.
- 28.08.2018 01:02
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.