Вопрос по информатике:
Напишите программу вычисления выражения:
s = x^3 + x^5 + x^n,
где x и n вводятся с клавиатуры.
Используйте функцию вычисления степени.
- 11.07.2017 10:53
- Информатика
- remove_red_eye 17904
- thumb_up 44
Ответы и объяснения 1
function pow(n: integer; a: integer): biginteger;
begin
var prod:biginteger:=1;
for var i:=1 to a do prod*=n;
result:=prod;
end;
begin
var x:=readinteger('x =');
write ('s = ', pow(x, 3)+pow(x, 5)+pow(x, readinteger('n =')));
end.
- 12.07.2017 06:17
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.