Вопрос по информатике:
Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке.
Входные данные
На вход программы подаётся символьная строка.
Выходные данные
Программа должна вывести количество различных символов в этой строке.
Примеры
входные данные
aB122AB
выходные данные
5
Pascal ABC 1.8
- 24.12.2017 00:40
- Информатика
- remove_red_eye 16451
- thumb_up 45
Ответы и объяснения 1
s: string;
i, cnt: integer;
c: char;
begin
used := [];
readln(s);
for i := 1 to length(s) do
include(used, s[i]);
cnt := 0;
for c := #0 to #255 do
if (c in used) then
cnt := cnt + 1;
writeln(cnt);
end.
- 25.12.2017 10:34
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.