Вопрос по информатике:
Напишите программу (pascal)
Найти сумму вводимых с клавиатуры чисел, которые отрицательные.
- 27.08.2017 06:12
- Информатика
- remove_red_eye 1749
- thumb_up 22
Ответы и объяснения 2
var sum,a: integer;
begin
sum:=0;
repeat
readln(a);
if a<0 then sum:=sum+a;
until (a=0);
writeln(sum);
end.
- 28.08.2017 11:45
- thumb_up 15
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма отрицательных чисел равна ',
ReadSeqRealWhile('Ввод завершайте нулём:',x->x0).Where(x->x<0).Sum)
end.
Пример
Ввод завершайте нулём: 2.5 -4 -6.25 5.143 11 -8 0
Сумма отрицательных чисел равна -18.25
- 30.08.2017 00:49
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.